What if instead our votes were just valued to scale with the level of a programer. I agree with you that my opinion means significantly less than someone with a higher kyu
Well, I think that's wrong: the natural incstinct as a programmer is (or should be) to made the code clear and that includes variables that should be readable, consistent vs the code and logical so others (or our future ourselves) will know what the heck was a variable for. Obviously not in a short kata nor in some conditional/bucle sentences but in long programs, right?
But that's being super-pedantic since you're returning a list and not an array. It's a shared description. Imo returning a tuple in this context makes more sense for Python.
Bro just needed to shorten the variable name just like the natural instinct of any programmer, also I don't know why I got sent a kyu 8 that took me seconds.
I think the biggest problem is (almost) everyone can vote.
I consider myself prety much a beginner and have eroniously voted for less efficient code because I thought it was the best. Maybe only users with high kuy score should be able to vote for best practices. Or even better, active people vetted by mods.
Back in the old days when many people were completing this kata, the starting code was:
defbool_to_word(bool):
# TODO
If you edit/fork the kata and look at the "Complete Solution", you'll see the legacy of this format is still in place (it's just in a non-public location).
Most kata writers don't bother changing given variable names, since that's not part of the "problem" we're being asked to solve.
So, yeah, people are right that it shouldn't be bool, which is why someone updated the kata to change the starting code to boolean (which, IMO, is just as bad of a name, since it's still the name for a variable type, even if Python proper never uses it; it's like Hungarian Notation, except it's not just a notation, it's the whole name). But, you should keep kata updates in mind when talking about people's ancient solutions: the ground has shifted.
I love how you changed the paramter to 'bool' to match the function name
In fact,
int
is already enough to remove the decimal part.What if instead our votes were just valued to scale with the level of a programer. I agree with you that my opinion means significantly less than someone with a higher kyu
whats the bottom line mean
nice
Well, I think that's wrong: the natural incstinct as a programmer is (or should be) to made the code clear and that includes variables that should be readable, consistent vs the code and logical so others (or our future ourselves) will know what the heck was a variable for. Obviously not in a short kata nor in some conditional/bucle sentences but in long programs, right?
there's no problem? is there a problem? what is the problem?
and what's the problem if we only accept bool values?
yep)
But that's being super-pedantic since you're returning a list and not an array. It's a shared description. Imo returning a tuple in this context makes more sense for Python.
Even though they say return array not tuple test cases are passed.
Here you return tuple instead of array
Bro just needed to shorten the variable name just like the natural instinct of any programmer, also I don't know why I got sent a kyu 8 that took me seconds.
I think the biggest problem is (almost) everyone can vote.
I consider myself prety much a beginner and have eroniously voted for less efficient code because I thought it was the best. Maybe only users with high kuy score should be able to vote for best practices. Or even better, active people vetted by mods.
couldn't agree more, i'm sick of people voting best practice just random stuff, the voting mechanism should be changed
Back in the old days when many people were completing this kata, the starting code was:
If you edit/fork the kata and look at the "Complete Solution", you'll see the legacy of this format is still in place (it's just in a non-public location).
Most kata writers don't bother changing given variable names, since that's not part of the "problem" we're being asked to solve.
So, yeah, people are right that it shouldn't be
bool
, which is why someone updated the kata to change the starting code toboolean
(which, IMO, is just as bad of a name, since it's still the name for a variable type, even if Python proper never uses it; it's like Hungarian Notation, except it's not just a notation, it's the whole name). But, you should keep kata updates in mind when talking about people's ancient solutions: the ground has shifted.Loading more items...