Of course! How silly of me...
All the imports make the eggs taste better :)
How is this "best practice"?
You're calling lower() n more times than you need to
This comment is hidden because it contains spoiler information about the solution
maybe useful too
This is really good, but it can be wroten more readable
if PEP8 told you to jump off a cliff, would you do it?
PEP8 is cruying.
I agree 'x' and 'f' are terrible names, particularly for readability
wow! so first time for me actually using a list comprehension. didnt realise you could shorten it yet again in the return line.